Pages

dissabte, 26 novembre de 2011

CORRECTOR EN CATALÀ DE LIBREOFFICE


Han passat molts dies des del meu últim post. He estat molt ocupat amb treballs i exàmens. Ara que tinc temps, he fet aquesta entrada per parlar de LibreOffice. Més concretament de la instal·lació del corrector ortogràfic. He tingut alguns problemes per a fer-lo funcionar i com que ho he aconseguit, m'agradaria compartir-ho amb vosaltres.

Abans de començar, heu de saber que no se si amb Windows també hi ha problemes. Jo utilitzo Linux, i quan faig servir Windows, normalment treballo amb MS Office [Per què???*]. La versió que he utilitzat és LibreOffice 3.4.4 OOO340m1 (Build:402). També heu de saber que faig servir Ubuntu Oneric 11.10.

EL problema?
El fet és que vaig instal·lar el paquet d'idioma via terminal sense cap problema, però quan el vaig provar no funcionava. Vaig reiniciar l'ordinador per si de cas però tampoc anava. Després de reinstal·lar-lo tres o quatre cops, tampoc anava. No feia la seva funció!

Començant des de zero, us explicaré com vaig instal·lar i solucionar el problema:

En primer lloc vaig actualitzar els repositoris.

$ sudo apt-get update

Vaig instal·lar el metapaquet** de LibreOffice.

$ sudo apt-get install libreoffice

Després vaig instal·lar el paquet d'idioma (català).

$ sudo apt-get install libreoffice-l10n-ca

Si voleu nstal·lar el paquet d'un altre idoma, podeu consultar quins estàn disponibles amb la comanda següent:

$ aptitude search libreoffice |grep libreoffice-l10n

Això us mostrara els paquests disponibles d'idiomes. Com podreu comprovar, només canvien les dos últimes lletres, que corresponen al codi de cada país o idioma.

Aquí és on el vaig provar i vaig veure que no funcionava. Ja sabeu com instal·lar el paquet d'idioma, però si veieu que no funciona, podeu provar de fer els passos següents:

Obriu el Language Support:

[Alt]+[F2] > 'gnome-languagelselector' (sense les cometes)

Si us demana instal·lar alguna cosa abans de començar, instal·leu-ho.


Tot seguit, feu clic al botó Install/Remove Languages en el requadre que apareix, marqueu els idiomes a instal·lar (o desmarqueu els que voleu treure). En el meu cas, el català, ja que el necessito pel corrector. Instal·leufent clic a Apply changes i comproveu els resultats.


Espero que no tingueu cap problema. La veritat és que no estic segur de si aquesta és la solució al problema.


* Que per què utilitzo MS Office? Be, si us heu fet aquesta pregunta, la resposta és molt simple. Funciona i des del meu punt de vista, és la millor suite d'ofimàtica que existeix actualment. Sincerament, si el pogués instal·lar en Linux sense capes de compatibilitat ni històries rares, seria el programa que utilitzaria per defecte. 
OpenOffice i LibreOffice son bones suites, i van molt bé. Cobreixen totes les necessitats, però MS Office 2007-2010 faciliten moltes tasques.


** Un metapaquet és com un paquet normal, amb la diferència de que el seu contingut no és un programa sino un conjunt de referències a altres paquets. En el cas d'aquest post, els paquets als quals fa referència són:
 * LibreOffice-escriptor: Processador de textos  * LibreOffice-Calc: Full de càlcul  * LibreOffice d'impressionar: Presentació  * LibreOffice a dibuixar: Dibuix  * LibreOffice-base: Base de dades  * LibreOffice-matemàtiques: Editor d'equacions  * LibreOffice-filtre-mobiledev: Dispositius mòbils filtres 

Cap comentari:

Publica un comentari a l'entrada